Commit 92124b54 authored by Roland Levillain's avatar Roland Levillain
Browse files

Require Doxygen 1.5.6 at bootstrapping time.

	* bootstrap: Here.
	(require): Be more tolerant w.r.t. version messages.
parent 3e348609
2010-03-08 Roland Levillain <roland@lrde.epita.fr>
Require Doxygen 1.5.6 at bootstrapping time.
* bootstrap: Here.
(require): Be more tolerant w.r.t. version messages.
2010-03-08 Roland Levillain <roland@lrde.epita.fr>
* bootstrap: Fix a typo in an error message.
......
......@@ -83,7 +83,7 @@ version_compare ()
# Test that TOOL exists, and its version is at least REQUIREMENT.
require ()
{
local version=$($1 --version | sed -n 's/.*[^0-9.]\([0-9][0-9.]*\).*/\1/p;q')
local version=$($1 --version | sed -n 's/[^0-9.]*\([0-9][0-9.]*\).*/\1/p;q')
test x"$version" != x ||
fatal "$1 is required"
case $(version_compare "$2" "$version") in
......@@ -125,6 +125,8 @@ done
export LIBTOOLIZE=$libtoolize
require $libtoolize 1.5.22
require doxygen 1.5.6
# Tell what's going on.
set -x
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment