Commit fe59cbe5 authored by Edwin Carlinet's avatar Edwin Carlinet
Browse files

Fix range-v3 version in CMakeLists.

parent 8ca38304
include(CMakePackageConfigHelpers)
find_package(Boost 1.58 REQUIRED)
find_package(range-v3 0.4.0 REQUIRED)
find_package(range-v3 0.5.0 REQUIRED)
find_package(FreeImage REQUIRED)
find_package(TBB)
......@@ -52,7 +52,7 @@ target_sources(Pylene PRIVATE
target_compile_features(Pylene PUBLIC cxx_std_17)
# Add concepts support for gcc > 7.2 with -fconcepts
if (CMAKE_COMPILER_IS_GNUCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.2)
if (CMAKE_COMPILER_IS_GNUCXX AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.2)
target_compile_options(Pylene PUBLIC -fconcepts)
find_package(cmcstl2 REQUIRED)
target_link_libraries(Pylene PUBLIC stl2)
......
include(CMakeFindDependencyMacro)
find_dependency(Boost 1.58)
find_dependency(range-v3 0.4.0)
find_dependency(range-v3 0.5.0)
if (CMAKE_COMPILER_IS_GNUCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.2)
find_dependency(cmcstl2)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment