Solve too much errors + start working on tests

8 jobs for development/fits-plugin in 1 minute and 57 seconds (queued for 8 seconds)
Name Stage Failure
failed
distcheck-linux-clang12-debug Build
ERROR: Failed requirement 'cfitsio/4.0.0' from 'conanfile.py (pylene/head)'
ERROR: Unable to find 'cfitsio/4.0.0' in remotes
Uploading artifacts for failed job
Uploading artifacts...
WARNING: build/tests/UT*.xml: no matching files
WARNING: build/bench/tests/UT*.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
distcheck-linux-gcc10-debug Build
ERROR: Failed requirement 'cfitsio/4.0.0' from 'conanfile.py (pylene/head)'
ERROR: Unable to find 'cfitsio/4.0.0' in remotes
Uploading artifacts for failed job
Uploading artifacts...
WARNING: build/tests/UT*.xml: no matching files
WARNING: build/bench/tests/UT*.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
distcheck-linux-clang10-debug Build
cfitsio/4.0.0: Trying with 'lrde-public'...
ERROR: Failed requirement 'cfitsio/4.0.0' from 'conanfile.py (pylene/head)'
ERROR: Unable to find 'cfitsio/4.0.0' in remotes
Uploading artifacts for failed job
Uploading artifacts...
WARNING: build/tests/UT*.xml: no matching files
WARNING: build/bench/tests/UT*.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
documentation Build
[env]
CC=gcc
CXX=g++
cfitsio/4.0.0: Not found in local cache, looking in remotes...
cfitsio/4.0.0: Trying with 'conan-center'...
cfitsio/4.0.0: Trying with 'lrde-public'...
ERROR: Failed requirement 'cfitsio/4.0.0' from 'conanfile.py (pylene/head)'
ERROR: Unable to find 'cfitsio/4.0.0' in remotes
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
distcheck-linux-gcc11-debug Build
cfitsio/4.0.0: Trying with 'lrde-public'...
ERROR: Failed requirement 'cfitsio/4.0.0' from 'conanfile.py (pylene/head)'
ERROR: Unable to find 'cfitsio/4.0.0' in remotes
Uploading artifacts for failed job
Uploading artifacts...
WARNING: build/tests/UT*.xml: no matching files
WARNING: build/bench/tests/UT*.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1