Commit 74804707 authored by Alexandre Duret-Lutz's avatar Alexandre Duret-Lutz
Browse files

Remove the configure check for Boost, since we do not use it anymore.

* README: Do not mention Boost.
* configure.ac: Do not check for Boost.
* m4/boost.m4: Delete.
parent 92ef3e10
......@@ -33,8 +33,6 @@ later). Especially, Python's headers files should be installed. If
you don't have Python installed, you should run configure with
the --disable-python option (see below).
The Boost libraries should also be installed.
Third-party dependencies
------------------------
......
......@@ -108,7 +108,6 @@ fi
AX_CHECK_BUDDY
AX_CHECK_GSPNLIB
AX_CHECK_BOOST([1.34], [103400])
AC_CHECK_HEADERS([sys/times.h])
AC_CHECK_FUNCS([times srand48 drand48 kill alarm])
......
AC_DEFUN([AX_CHECK_BOOST],
[
AC_LANG_PUSH([C++])
AC_CHECK_HEADER([boost/version.hpp],, [AC_MSG_ERROR([
Cannot find Boost headers. If they are installed on an unusuall path on
your system, please run configure with the suitable CPPFLAGS and LDFLAGS
options. For instance if it is installed in /opt/boost/ please use:
./configure CPPFLAGS="-I/opt/boost/include" LDFLAGS="-L/opt/boost/lib"
])])
AC_CACHE_CHECK([whether Boost version is >= $1], [ac_cv_boost_recent],
[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@%:@include <boost/version.hpp>
]], [[
#if BOOST_VERSION >= $2
// Everything is okay
#else
# error Boost version is too old
#endif
]])],[
ac_cv_boost_recent=yes
],[
ac_cv_boost_recent=no
])])
if test "x$ac_cvboost_recent" = xno; then
AC_MSG_ERROR([Boost appears to be too old. We need version $1 or more recent.])
fi
AC_LANG_POP([C++])
])
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment