Commit 98a8b891 authored by Alexandre Duret-Lutz's avatar Alexandre Duret-Lutz
Browse files

* doc/org/init.el.in: Work around obsolete ELPA signatures.

parent 7f21d3ff
Pipeline #13242 passed with stages
in 289 minutes and 4 seconds
......@@ -3,6 +3,15 @@
(setq debug-on-error t)
;;; Some combination of GNU TLS and Emacs fail to retrieve archive
;;; contents over https.
;;; https://www.reddit.com/r/emacs/comments/cdf48c/failed_to_download_gnu_archive/
;;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34341
(if (and (version< emacs-version "26.3") (>= libgnutls-version 30600))
(setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3"))
; work around obsolete ELPA signatures :-(
(setq package-check-signature 'nil)
(package-initialize)
(require 'cl)
(setq features-before features)
......@@ -11,13 +20,6 @@
(print (org-version nil t t))
(print (concat "Org " org-version))
; Some combination of GNU TLS and Emacs fail to retrieve archive
; contents over https.
; https://www.reddit.com/r/emacs/comments/cdf48c/failed_to_download_gnu_archive/
; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34341
(if (and (version< emacs-version "26.3") (>= libgnutls-version 30600))
(setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3"))
; The Org version that ships with emacs is usually too old.
(when (version< org-version "9.1")
(warn "Org-mode is too old; attempting to download a more recent version")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment