Commit a5f08033 authored by Alexandre Duret-Lutz's avatar Alexandre Duret-Lutz
Browse files

Python 3.5 is now needed

* NEWS, README, HACKING, doc/org/install.org, m4/pypath.m4: Adjust.
parent bc063b13
......@@ -42,7 +42,7 @@ since the generated files they produce are distributed.)
A complete LaTeX distribution, including latexmk and extra fonts
like dsfont.sty.
ImageMagick
Python >= 3.3, IPython >= 2.3
Python >= 3.5, IPython >= 2.3
Jupyter >= 4, with nbconvert
GraphViz
Java >= 1.7 (needed to run PlantUML while generating the doc)
......
New in spot 2.10.0.dev (not released yet)
Nothing yet.
- Python 3.5 is now required.
New in spot 2.10 (2021-11-13)
......
......@@ -76,7 +76,7 @@ Requirements
Spot requires a C++17-compliant compiler. G++ 7.x or later, as well
as Clang++ 5.0 or later should work.
Spot expects a complete installation of Python (version 3.3 or later).
Spot expects a complete installation of Python (version 3.5 or later).
Especially, Python's headers files should be installed. If you don't
have Python installed, and do NOT want to install it, you should run
configure with the --disable-python option (see below).
......
......@@ -22,7 +22,7 @@ successful development build]].
Spot requires a C++17-compliant compiler. =g++= 7.0 or later, as well
as =clang++= 5.0 or later should work.
Spot expects a complete installation of Python (version 3.3 or later).
Spot expects a complete installation of Python (version 3.5 or later).
Especially, Python's headers files should be installed (the package to
install has a name like =python-dev= or =libpython3-dev= in most
distributions). If you don't have Python installed, and do NOT want
......
AC_DEFUN([adl_CHECK_PYTHON],
[AM_PATH_PYTHON([3.3])
[AM_PATH_PYTHON([3.5])
case $PYTHON in
[[\\/$]]* | ?:[[\\/]]* );;
*) AC_MSG_ERROR([The PYTHON variable must be set to an absolute filename.]);;
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment