Commit e9e132dd authored by Alexandre Duret-Lutz's avatar Alexandre Duret-Lutz
Browse files

[lbtt] Adjust parsers to accommodate old and new versions of Automake.

* src/Config-parse.yy, src/Ltl-parse.yy, src/NeverClaim-parse.yy:
Rename these as..
* src/Config-parse.y, src/Ltl-parse.y, src/NeverClaim-parse.y:
... these.
* src/Config-parse_.cc, src/Ltl-parse_.cc,
src/NeverClaim-parse_.cc: New files to hack around
incompatibilities between Automake 1.12 and Automake 1.11.
* src/Makefile.am: Adjust.
* NEWS: Mention this change.
parent b98c4724
2012-06-19 Alexandre Duret-Lutz <adl@lrde.epita.fr>
Adjust parsers to accommodate old and new versions of Automake.
* src/Config-parse.yy, src/Ltl-parse.yy, src/NeverClaim-parse.yy:
Rename these as..
* src/Config-parse.y, src/Ltl-parse.y, src/NeverClaim-parse.y:
... these.
* src/Config-parse_.cc, src/Ltl-parse_.cc,
src/NeverClaim-parse_.cc: New files to hack around
incompatibilities between Automake 1.12 and Automake 1.11.
* src/Makefile.am: Adjust.
* NEWS: Mention this change.
2012-05-21 Alexandre Duret-Lutz <adl@lrde.epita.fr>
Make it clearer this is not LBTT 1.2.1.
......
......@@ -23,6 +23,7 @@ Version 1.2.1a
* Fix compilation with newer versions of Bison.
* Fix compilation on Intel's icpc, and with recent version of G++.
* Fix compilation with newer versions of Automake.
* Fix construction of manual ("make dvi" and "make pdf") for recent
version of texinfo.
* Fix generation of random formulae on 64bit machines. (They were
......
// This is a hack to support both Automake <= 1.11.x, and Automake >=
// 1.12.x The problem with is that old versions used to create
// parse.h, and parse.cc from a parse.yxx grammar, while new versions
// create parse.hxx and parse.cc.
//
// We want to support both version of Automake, because 1.11.x is
// fairly well distributed, and 1.12 did not make it into Debian 7.0.
//
// Yet it's difficult to support both versions because of the name
// change. Our hack is to rename parse.yxx as parse.y, so that
// automake will generate rule to build parse.h and parse.c, and then
// this parse_.cc file is used to compile parse.c in C++. This way we
// always have a parse.h file regardless of the Automake version.
//
// We can fix this mess once Automake 1.12 is available everywhere.
#include "Config-parse.c"
// This is a hack to support both Automake <= 1.11.x, and Automake >=
// 1.12.x The problem with is that old versions used to create
// parse.h, and parse.cc from a parse.yxx grammar, while new versions
// create parse.hxx and parse.cc.
//
// We want to support both version of Automake, because 1.11.x is
// fairly well distributed, and 1.12 did not make it into Debian 7.0.
//
// Yet it's difficult to support both versions because of the name
// change. Our hack is to rename parse.yxx as parse.y, so that
// automake will generate rule to build parse.h and parse.c, and then
// this parse_.cc file is used to compile parse.c in C++. This way we
// always have a parse.h file regardless of the Automake version.
//
// We can fix this mess once Automake 1.12 is available everywhere.
#include "Ltl-parse.c"
BUILT_SOURCES = Config-parse.h NeverClaim-parse.h
BUILT_SOURCES = Config-parse.c NeverClaim-parse.c Ltl-parse.c
AM_YFLAGS = -d
bin_PROGRAMS = lbtt lbtt-translate
......@@ -10,7 +10,7 @@ lbtt_SOURCES = \
BuchiAutomaton.cc \
BuchiProduct.h \
BuchiProduct.cc \
Config-parse.yy \
Config-parse_.cc \
Config-lex.ll \
Configuration.h \
Configuration.cc \
......@@ -26,7 +26,7 @@ lbtt_SOURCES = \
LbttAlloc.h \
LtlFormula.h \
LtlFormula.cc \
Ltl-parse.yy \
Ltl-parse_.cc \
main.cc \
PathEvaluator.h \
PathEvaluator.cc \
......@@ -56,7 +56,7 @@ lbtt_SOURCES = \
UserCommandReader.cc \
UserCommands.h \
UserCommands.cc
EXTRA_lbtt_SOURCES = gnu-getopt.h
EXTRA_lbtt_SOURCES = gnu-getopt.h Config-parse.y Ltl-parse.y
lbtt_LDADD = @LIBOBJS@ @READLINELIBS@
lbtt_translate_SOURCES = \
......@@ -72,8 +72,8 @@ lbtt_translate_SOURCES = \
LbtWrapper.h \
LtlFormula.h \
LtlFormula.cc \
Ltl-parse.yy \
NeverClaim-parse.yy \
Ltl-parse_.cc \
NeverClaim-parse_.cc \
NeverClaim-lex.ll \
NeverClaimAutomaton.h \
NeverClaimAutomaton.cc \
......@@ -88,5 +88,5 @@ lbtt_translate_SOURCES = \
translate.h \
translate.cc \
TranslatorInterface.h
EXTRA_lbtt_translate_SOURCES = gnu-getopt.h
EXTRA_lbtt_translate_SOURCES = gnu-getopt.h Ltl-parse.y NeverClaim-parse.y
lbtt_translate_LDADD = @LIBOBJS@
// This is a hack to support both Automake <= 1.11.x, and Automake >=
// 1.12.x The problem with is that old versions used to create
// parse.h, and parse.cc from a parse.yxx grammar, while new versions
// create parse.hxx and parse.cc.
//
// We want to support both version of Automake, because 1.11.x is
// fairly well distributed, and 1.12 did not make it into Debian 7.0.
//
// Yet it's difficult to support both versions because of the name
// change. Our hack is to rename parse.yxx as parse.y, so that
// automake will generate rule to build parse.h and parse.c, and then
// this parse_.cc file is used to compile parse.c in C++. This way we
// always have a parse.h file regardless of the Automake version.
//
// We can fix this mess once Automake 1.12 is available everywhere.
#include "NeverClaim-parse.c"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment