Commit 234c9c29 authored by Alexandre Duret-Lutz's avatar Alexandre Duret-Lutz

require bison 3.0 and fix obsolete api.location.type usage

* spot/parseaut/parseaut.yy, spot/parsetl/parsetl.yy: Explicitly Bison
3.0, and use a code argument instead of an (deprecated) string
argument for api.location.type.
parent fa24cca7
Pipeline #4442 passed with stage
in 59 minutes and 26 seconds
......@@ -17,6 +17,7 @@
** You should have received a copy of the GNU General Public License
** along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
%require "3.0"
%language "C++"
%locations
%defines
......@@ -26,7 +27,7 @@
%error-verbose
%parse-param {void* scanner}
%lex-param {void* scanner} { PARSE_ERROR_LIST }
%define api.location.type "spot::location"
%define api.location.type {spot::location}
%code requires
{
......
......@@ -21,6 +21,7 @@
** You should have received a copy of the GNU General Public License
** along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
%require "3.0"
%language "C++"
%locations
%defines
......@@ -29,7 +30,7 @@
%error-verbose
%expect 0
%lex-param { spot::parse_error_list& error_list }
%define api.location.type "spot::location"
%define api.location.type {spot::location}
%code requires
{
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment